View Issue Details

IDProjectCategoryView StatusLast Update
0000120FromDual Ops Center for MariaDB and MySQL (focmm)Generalpublic2014-05-02 20:55
Reporterabdel-mawla Assigned Tooli  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionwon't fix 
PlatformLinuxOSCentosOS Version6.x
Product Version1.0.0 
Target Version1.0.0 
Summary0000120: Stop Slave button should be disabled when the slave stopped
DescriptionAfter stopping a slave, the "Stop Slave" button should be disabled to avoid "Slave already has been stopped" error.
The same idea is already implemented in the "Start Slave" button. When the slave is already running the Start Slave button is disabled.

Note:
"Stop IO Thread" and "Stop SQL Thread" buttons are working as expected.
Steps To Reproduce1- Register master and slave database instances.
2- Stop the slave by either click on both stop SQL and stop IO thread buttons or click only on Stop Slave button.
3- "Stop Slave" button will be still enabled.
TagsNo tags attached.

Activities

oli

2014-05-02 20:55

developer   ~0000104

Comment from code:

// Never disable this button because even if both threads are set to
// NO we need to stop slave for CHANGE MASTER command!

There are some strange cases where both replication threads do NOT work but we still have to STOP SLAVE... So we always must have the chance to do this. User error is the smaller evil.

Issue History

Date Modified Username Field Change
2014-02-20 10:00 abdel-mawla New Issue
2014-02-20 10:00 abdel-mawla Status new => assigned
2014-02-20 10:00 abdel-mawla Assigned To => oli
2014-05-02 20:55 oli Note Added: 0000104
2014-05-02 20:55 oli Status assigned => resolved
2014-05-02 20:55 oli Resolution open => won't fix