View Issue Details

IDProjectCategoryView StatusLast Update
0000125FromDual Ops Center for MariaDB and MySQL (focmm)Generalpublic2014-05-02 21:27
Reporterabdel-mawla Assigned Tooli  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSCentosOS Version6.x
Product Version0.1 
Target Version0.2Fixed in Version0.2 
Summary0000125: Start database and Stop database buttons should be disabled when the database is already started or stopped respectively
DescriptionWhen the database instance is started, the "Start database" button should be disabled. The same behavior should be applied if the database instance is stopped, the "Stop database" button should be disabled.
Steps To Reproduce1- Click on the "Database" tab at the very top of MOC.
2- Choose a database instance from the already registered ones.
3- Click on the "Operations" tab.
4- Both buttons (Start database and Stop database) are enabled while only one should be enabled and the other one should be disabled depending on the status of selected instance.
TagsNo tags attached.

Activities

oli

2014-05-02 21:27

developer   ~0000107

fixed in rev246
I was first concerned that disabling the stop button is bad idea because then we cannot force the db shutdown.
But shutdown and check is using the both the network. so if we cannot check we also cannot force shutdown any more. thus feature request is ok until we have the local shutdown feature.

Issue History

Date Modified Username Field Change
2014-03-05 10:03 abdel-mawla New Issue
2014-03-05 10:03 abdel-mawla Status new => assigned
2014-03-05 10:03 abdel-mawla Assigned To => administrator
2014-03-05 10:20 abdel-mawla Assigned To administrator => oli
2014-03-05 10:20 abdel-mawla Status assigned => new
2014-03-05 10:21 abdel-mawla Status new => assigned
2014-05-02 21:27 oli Note Added: 0000107
2014-05-02 21:27 oli Status assigned => resolved
2014-05-02 21:27 oli Resolution open => fixed
2014-05-02 21:27 oli Product Version 1.0.0 => 0.1
2014-05-02 21:27 oli Fixed in Version => 0.2
2014-05-02 21:27 oli Target Version 1.0.0 => 0.2