View Issue Details

IDProjectCategoryView StatusLast Update
0000138FromDual Performance Monitor for MariaDB and MySQL (fpmmm)fpmmm Agentpublic2014-05-24 13:15
Reporteroli Assigned Tooli  
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformIndependentOSn.a.OS Versionall
Product Version0.9.1 
Target Version0.9.3Fixed in Version0.9.3 
Summary0000138: database down does not trigger alert
DescriptionIf database is down values are not reported to zabbix service and thus no alert is triggered.
Steps To Reproducevi FromDualMySQLmysql.inc / vi FromDualMySQLmysql.lib
 18 $aGlobalVariablesToSend = array(
 19 'alive'

--> Exit is done but alive should be returned instead!
--> All values should be set to 0 to get better graphs!
Additional Information1769:2014-05-03 17:21:01.860 - INFO: FromDual Performance Monitor for MySQL (rev415) run started.
1769:2014-05-03 17:21:03.147 - ERR : Cannot read PID file /tmp/mysql-33006.pid. Either file does not exist or I have no read permissions. Are you sure the process is running?
1769:2014-05-03 17:21:03.164 - ERR : DBI connect with database=mysql, host=localhost, port=33006 and user=root failed: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
1769:2014-05-03 17:21:03.164 - DBG : Database connection failed (rc=2400).
1769:2014-05-03 17:21:03.166 - ERR : DBI connect with database=mysql, host=localhost, port=33006 and user=root failed: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
1769:2014-05-03 17:21:03.166 - DBG : Database connection failed (rc=2500).
1769:2014-05-03 17:21:03.170 - ERR : DBI connect with database=mysql, host=localhost, port=33006 and user=root failed: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
1769:2014-05-03 17:21:03.170 - DBG : Database connection failed (rc=2600).
1769:2014-05-03 17:21:03.171 - ERR : DBI connect with database=mysql, host=localhost, port=33006 and user=root failed: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
1769:2014-05-03 17:21:03.171 - DBG : Database connection failed (rc=2100).
1769:2014-05-03 17:21:03.171 - INFO: FromDual Performance Monitor for MySQL run finshed (rc=0).
TagsNo tags attached.

Activities

oli

2014-05-08 20:24

developer   ~0000118

duplicate of 0000027

oli

2014-05-24 13:15

developer   ~0000119

fixed in rev420

Issue History

Date Modified Username Field Change
2014-05-06 08:19 oli New Issue
2014-05-06 08:19 oli Status new => assigned
2014-05-06 08:19 oli Assigned To => oli
2014-05-06 13:22 oli Target Version 1.0.0 => 0.9.3
2014-05-08 20:24 oli Note Added: 0000118
2014-05-24 13:15 oli Note Added: 0000119
2014-05-24 13:15 oli Status assigned => resolved
2014-05-24 13:15 oli Resolution open => fixed
2014-05-24 13:15 oli Fixed in Version => 0.9.3
2015-05-01 11:07 administrator Category mpm Agent => fpmmm Agent